Réparation d'un oscilloscope CRC type OC-342





Problème de synchro - Amplificateur Y



20. Où en suis-je ?

Un petit point avant d'aller plus loin, car j'avoue qu'on pourrait penser que je tourne en rond (ce qui n'est pas tout à fait faux ...):

Alimentation :

- Le régulateur qui génère +B1 est maintenant référencé par une tension stabilisée par zener (48V)
- Il doit être réglé de manière à avoir 100V entre +B1 et le châssis de l'appareil (ce qui donne +145V par rapport au -HT)
- Une résistance de 22 ohm / 10W doit être insérée en série avec le primaire du transfo (sur la position 220V) pour accepter un secteur de 230Veff

Base de Temps :

- La diode DJ23 (OA85) a été remplacée par une 1N4148 afin de bien bloquer le relaxateur-intégrateur
- Le trigger, le relaxateur et l'ampli de sortie sont opérationnels
- La synchro n'est pas toujours efficace, cela dépend de l'amplitude du signal Y mais aussi du réglage de fréquence de la BdT.


Voilà l'état de la révision. Il faut donc maintenant que je vérifie si ce problème de synchro est conceptuel ou bien s'il y a une panne.



21. Schéma de principe du préamplificateur/atténuateur

Pour vérifier si l'amplitude du signal de synchro est correcte, je vais analyser les étages Y jusqu'à la sortie qui produit le signal de synchro interne.
Bien sûr, globalement la voie Y a l'air de fonctionner correctement puisque le signal d'entrée est bien visible sur l'écran, cela veut dire que de l'entrée Y aux plaques de déviation verticale du tube, tout va à peu près bien ...
Je dis "à peu près" car j'ai quand même repéré un petit défaut : suivant la position du commutateur KY, le "zéro" n'est pas le même : la trace se décale de quelques divisions lorsqu'on passe d'une sensibilité à une autre.
C'est peut-être un problème de contact dans KY ou autre chose; bref, voici déjà les schémas de la voie Y complète :


L'atténuateur d'entrée




Le préampli Y




L'ampli de sortie

J'ai simplifié les schémas de l'atténuateur et du préampli pour y voir plus clair :


Schéma de principe pour les sensibilités de 50V/d à 0,1V/d

Pour ces 9 sensibilités, on n'a pas vraiment d'amplification car L100a est montée en anode commune (gain = 1) et L100b n'est utilisée que pour faire une impédance de charge au diviseur de tension PC2/RY4/RY5/RY6.
L'atténuation nécessaire est "découpée" en 2 : par l'atténuateur d'entrée qui comporte 3 attéunations possibles (0,01 / 0,1 et 1) et par ce diviseur qui "peaufine" en procurant 3 adapatations intermédiaires (1 / 0,5 / 0,2)
S1 et S2 sont les entrées de polarité opposée de l'ampli de sortie. Autrement dit l'ampli de sortie amplifie la différence entre S1 et S2, soit (S1-S2)




Schéma de principe pour les sensibilités de 0,05V/d à 0,01V/d

Pour ces 3 sensibilités, il n'y a pas d'atténuation d'entrée (A=1) et il faut amplifier car la sensibilité de l'ampli de sortie est insuffisante. C'est le rôle de L100b qui a un gain de -10. Les sensibilités intermédiaires sont procurées par un second diviseur de tension (RY2 et RY3), et comme l'ampli de sortie amplifie toujours la différence entre S1 et S2, cette différence est égale à -9.S2 (-10+1).

Pour vérifier ces étages il suffit d'injecter un signal d'amplitude connue et de relever les amplitudes des sorties selon la position de KY.



22. Mesures sur le préamplificateur/atténuateur

Commençons par les 9 calibres les moins sensibles :



J'ai donc injecté sur la douille d'entrée Y un signal sinusoïdal d'amplitude 5V (10Vcrête à crête = 10Vpp) à la fréquence de 200Hz (T=5ms donc).
L'oscillo a été réglé sur 0,5V/div (position 7), ainsi il n'y a pas d'atténuation d'entrée (et donc il est logique que sur l'écran, la trace "déborde" largement !
Puis j'ai relevé tour à tour les signaux le long de la chaine; tout d'abord, l'atténuateur d'entrée :






Il est normal de trouver B=A puisque sur la position 0,5V/div, il n'y a pas d'atténuation d'entrée




Sur la cathode de L100a, on a bien perdu dans l'impédance de sortie, qui, même si elle est faible, est loin d'être négligeable devant la charge (formée de PC2,RY4,RY5,RY6 et de l'impédance d'entrée de L100b)










Les amplitudes diminuent régulièrement et conformément aux rapports des résistances du pont diviseur




Il reste encore 1,3Vpp à l'entrée de L100b. Notez que l'indication de l'oscillo numérique est erronée car il y a des pics de tension (entourés en rose) qui doivent être provoqués par une alim à découpage voisine ...




Sur la position 7 de KY, cette sortie H n'est pas utilisée, mais on peut tout de même la mesurer.


Voici le schéma de principe du pont diviseur entre L100a et L100b, pour les positions 1 à 9, utile pour les analyses suivantes du fonctionnement :



Analyse en alternatif :

Globalement, ça a l'air d'aller. En effet, si on prend les valeurs d'amplitudes suivantes pour les points qui nous intéressent, c'est-à-dire les 3 points allant à la commutation (DEF) de l'entrée de gauche de l'ampli, et le point G allant à l'entrée de droite de l'ampli :

- point D = 7,5Vpp
- point E = 4,375Vpp
- point F = 2,5Vpp
- point G = 1,3Vpp

Et si on calcule les différences :

- D-G = 6,2Vpp
- E-G = 3,075Vpp
- F-G = 1,2Vpp

Puis les rapports :

- (D-G)/(F-G) = 5,17
- (E-G)/(F-G) = 2,56

On s'aperçoit qu'on est proche des rapports théoriques (5 et 2,5).

J'ai tout de même vérifié les 3 résistances :

- RY4 = 1000
- RY5 = 625
- RY6 = 402

La valeur de RY5 est acceptable (ça fait une erreur de 4%), mais je la changerai.

A noter que l'on peut calculer les impédances de sortie et d'entrée des lampes. En effet, L100a, montée en anode commune présente une impédance de sortie de l'ordre de Rk/(Ri.S) soit 18000/(5x8) = 450 ohm.
Pour L100b, montée en grille commune, la formule est la même. Mais on peut calculer ces 2 impédances à partir des mesures :

- on perd 10,1-8,9 = 1,2V aux bornes de l'impédance de sortie de L100a
- on a 1,3V aux bornes de l'impédance d'entrée de L100b, ce qui est très proche.
- J'ai mesuré PC2 : 308 ohm

- la résistance totale du pont est de (Zs + 308 + 1000 + 600 + 400 + Ze) et a à ses bornes 10,1V.
- il y a 2,5V aux bornes de (Zs+Ze) et 10,1V - 2,5V = 7,6V aux bornes des résistances qui valent au total 2308 ohm,
- on a donc : Zs+Ze = 2308*2,5/7,6 = 760 ohm environ. Donc Zs = Ze = 380 ohm environ (au lieu de 450 calculés)


Analyse en continu :

Normalement, on devrait avoir, quelque soit la position de KY choisie, c'est-à-dire qu'on choisisse le signal D, E ou F, la même composante continue que celle du signal G, afin que l'ampli différentiel de sortie élimine cette composante continue.
Or je vous rappelle que j'ai constaté justement que suivant la position choisie, la trace se déplaçait de l'une à l'autre, comme si la composante continue était différente.
Voyons cela de plus près :


Signal D : mini = -1,5V, maxi = +6,5V, valeur moyenne (= composante continue) = (-1,5+6)/2 = +2,25V




Signal E : mini = 0V, maxi = +4,3V, valeur moyenne = (0+4,3)/2 = +2,15V




Signal F : mini = +0,7V, maxi = +3,2V, valeur moyenne = (0,7+3,2)/2 = +1,95V




Signal G : mini = +1,3V, maxi = +2,6V, valeur moyenne = (1,3+2,6)/2 = +1,95V

Si maintenant on calcule les différences des valeurs moyennes obtenues :

- D-G = 2,25 - 1,95 = 0,3V
- E-G = 2,15 - 1,95 = 0,2V
- F-G = 1,95 - 1,95 = 0V

On s'aperçoit, qu'effectivement, aux entrées de l'ampli de sortie existe bien une composante continue qui peut, suivant le calibre choisi, être non nulle .

Bien sûr, il existe un réglage (équilibrage) qui agit sur la tension V1 de la grille de L100b, de manière à obtenir aux points C et G le même niveau continu .
Ainsi, du point de vue de la composante continue, il n'existe pas de différence de potentiel aux bornes du pont diviseur et par conséquent à aucun des points D,E et F.
A condition que les contacs électriques de KY ne soit pas oxydés au point de devenir des piles ... Ni que la commande de cadrage ne soit décalée !



23. Réglages et réparations de l'amplificateur vertical

Avant de régler l'équilibrage, j'ai changé la résistance RY5 qui avait un peu varié (625 au lieu de 600). Autant faire les choses bien.



J'ai aussi nettoyé les contacts de KY.

Pour régler l'équilibre, c'est-à-dire égaliser la composante continue sur les 2 entrées de l'ampli différentiel de sortie, il faut le faire sans s'occuper de la commande de cadrage.
Autrement dit, on ne peut pas utiliser la position de la trace sur l'écran pour faire le réglage. En effet, on peut toujours compenser un déséquilibre par la commande de cadrage, donc ce n'est pas parce que la trace est bien au milieu dans le sens vertical que l'équilibre est bon.
Le mieux est donc de faire le réglage en mesurant en différentiel la tension entre les 2 entrées de l'ampli, avec aucun signal en entrée Y

Voici un schéma qui explique la procédure :



On court-circuite l'entrée Y avec un strap, on se met sur un calibre qui supprime l'atténuateur d'entrée, et on branche un millivoltmètre continu entre les points C et G.
Il suffit alors de régler PC9 (équilibrage) pour obtenir une tension nulle .



Les points C et G sont tout simplement accessibles au niveau des 2 résistances de 18k, RE4 et RE5
Le potard PC9 du schéma est appelé "P100 équilibrage"


Voici deux vidéos montrant ce qui se passe lorsqu'on change de sensibilité verticale (cliquez sur les photos pour télécharger les vidéos):


Avant réglage de l'équilibrage : la ligne se décale selon la sensibilité


Après réglage de l'équilibrage : la ligne reste au centre de la hauteur, quelque soit la sensibilité choisie


Vérifions maintenant les 3 calibres les plus sensibles :



Il suffit d'injecter par exemple 1Vpp sur Y et de vérifier les amplitudes. En effet, il n'y a aucun réglage sur ces calibres, ce sont les "parents pauvres" de l'appareil ...
Il faut dire aussi qu'ils correspondent à des signaux faibles, souvent bien bruités, donc difficiles à mesurer, à synchroniseur, bref le constructeur n'a pas jugé pertinent de se compliquer la vie pour eux !

Déjà, gros problème dès qu'on passe sur ces calibres, la trace disparait (on la voit se déplacer très rapidement vers le haut et sortir de l'écran).
Je vérifie les tensions au niveau des points J et G, par rapport à la masse :
- sur G : +2,1 V environ, ce qui est normal
- sur J : +3,3 V, ce qui n'est pas normal du tout puisque la résistance RY1 fixe la tension à celle de la cathode de L100b, c'est-à-dire du point G.

Conclusion : CE1 fuit !
Je le change :



Et tout redevient normal : tension continue identique sur J et sur G, et la trace se centre bien sur l'écran.

Passons maintenant aux relevés des signaux suivant le calibre (en haut : G, en bas : J) :



Calibre : 0,05V/div
Amplitudes : J = 1,2Vpp, G = 0,2Vpp, donc J-G = 1Vpp
Donc, en injectant 1Vpp sur Y, et en se mettant sur ce calibre de 0,05V/div, on a un gain de 1, c'est-à-dire qu'on injecte 1Vpp à l'entrée de l'ampli.
Cela veut dire aussi que l'ampli L100b compense exactement le pont diviseur formé des résistances internes des lampes et de RY2 et RY3 (300/3100)




Calibre : 0,02V/div
Amplitudes : J = 2,8Vpp, G = 0,27Vpp, donc J-G = 2,53Vpp





Calibre : 0,01V/div
Amplitudes : J = 5,75Vpp, G = 0,55Vpp, donc J-G = 5,2Vpp

Bon, en tout cas, les rapports des différences sont corrects (on devrait trouver 1 / 2,5 / 5)


Voici maintenant les oscillogrammes relevés dans l'ampli Y (entrée = sinus 200Hz, 10Vpp, sensibilité = 2V/div) :



Entrées de l'ampli de sortie (grilles de L101a et L101b). On a à peu près 0,25Vpp de différence entre les signaux J et G

Les signaux relevés ensuite sont les suivants :







Sorties du premier étage. Notez la différence d'amplitude des signaux K et L





Sorties du second étage qui n'est qu'un adaptateur d'impédance, donc mêmes amplitudes et même différence

Voici d'ailleurs les deux signaux M et N en même temps :


Les amplitudes sont différentes : 1,52Vpp et 1,36Vpp

Ce n'est pas énorme comme différence, mais cela explique pourquoi la commande de cadrage vertical n'est pas du tout à mi-course. D'ailleurs voici l'allure de l'écran lorsqu'on règle cette commande à mi-course :



J'ai donc investigué et trouvé que la lampe L101 avait une triode bien fatiguée par rapport à l'autre. J'en ai trouvé une meilleure dans mon stock et je l'ai installée.
Puis j'ai réglé la commande de cadrage vertical à mi-course, puis j'ai réglé PC1 (ajustage cadrage) de façon à égaliser les amplitudes des signaux M et N :


Les amplitudes sont égales : 1,4Vpp

Une fois ce réglage effectué, la trace n'est pas au milieu de la hauteur, mais le cadrage vertical permet de la centrer et on est presque à mi-course, preuve que cette nouvelle 6BQ7 est meilleure que celle d'origine (en tout cas, ses 2 triodes sont presque identiques)
On peut d'ailleurs remarquer que c'est là un souci de conception : lorsque cette lampe vieillit, si une des triodes se fatigue plus vite que l'autre, on aura un problème pour rattraper le cadrage vertical. Bon, je ne vais pas non plus réétudier tout l'oscillo ...
Continuons les relevés :



Sorties du dernier étage, c'esr-à-dire celles qui sont reliées aux plaques de déviation verticale du tube. On a 31..32 Vpp sur chacune d'elles

Juste pour vérifier :

- une division sur l'écran mesure 6,25 mm (8 divisions = 50 mm)
- la trace obtenue (avec Y=10Vpp) est bien de 5 divisions (calibre 2V/div), donc 31,25 mm
- la tension différentielle des 2 plaques du tube est de 62Vpp environ
- la sensibilité calculée du tube est donc de 31,25/62 = 0,504 mm/V
- sur la donc du tube DG7-36 on a : sensibilité verticale comprise entre 0,49 et 0,59 mm/V
Conclusion : c'est ok. Et je considère que la chaine Y complète est opérationnelle !

Vous pouvez télécharger son schéma en PDF ICI



24. Vérification des étages de synchro

Maintenant que les étages de déviation verticale sont vérifiés, de l'entrée Y jusqu'aux plaques du tube cathodique, j'en déduis que le signal de synchro, SY-INT, prélevé sur la cathode de L102b est correct
Or je vous rappelle que j'avais un doute sur l'efficacité de la synchro. Il faut dire que lors des essais des étages Y, j'ai pu constater que la synchro fonctionnait correctement, du moins toujours de la même manière. Alors après tout, je me fais peut-être des idées ...
Voici comment je règle la stabilité de la trace :
- je choisis le bon calibre Y de manière à ce que la trace couvre le maximum d'amplitude dans le sens vertical
- je règle le vernier de la base de temps sur la position "calibré" (à fond à droite)
- je choisis le calibre de la base de temps pour obtenir de 2 à 5 périodes complètes
- je tourne le bouton rouge de synchro vers la droite à fond, puis doucement vers la gauche jusqu'à ce la trace se stabilise
- lorsqu'elle est stable, je peux retoucher le vernier pour modifier le nombre de périodes affichées sans que la stabilité disparaisse

A noter que si on veut faire une mesure précise de période (donc de fréquence) du signal observé, le vernier doit être sur la position "calibré" : on peut alors utiliser l'indication portée sur le calibre de la base de temps, qui donne la durée d'une division.

Je vais tout de même vérifier le cheminement du signal interne de synchro, de l'ampli vertical (L102b) jusqu'au trigger (L203a/L203b).
Avec un signal d'entrée de 10Vpp, 200Hz, calibre 2V/div, l'amplitude du signal prélevé sur la cathode de L102b est de 1,4 Vpp :



On retrouve ce signal sur une grille de L206 (selon la polarité choisie pour la synchro) :



Ce signal est amplifié en sortie de L206b :



Cependant, vous aurez remarqué que le signal sur la grille comporte une composante continue (par rapport à la masse) de plus de 2V ce qui n'est pas normal.
J'ai alors relevé les tensions autour de L206 :


Tensions par rapport au -HT (qui vaut -45V environ)

On a bien une tension presque nulle (par rapport à la masse) sur une des grilles (L206a), mais de plus de +2V sur l'autre grille (L206b). Bien sûr je soupçonne le condo de liaison CD21 :


Changement du condo de liaison

J'ai mesuré aussi les résistances de 1M (RH24 et RH25) : plus de 1,6M. Je les change et j'en ai profité aussi pour changer les condos CH28 et CH29 :



Et j'ai mesuré de nouveau les tensions autour de L206 :



Voilà qui est bien mieux ! Je peux continuer de relever les signaux :


Signal en sortie de L206b : on a gagné un peu en amplitude

Passons maintenant à l'écrêteur L205/L204, voici les tensions mesurées :


Toutes les tensions semblent normales, il n'y a pas à craindre de coupure de composants

Voyons les signaux :


Signal sur la grille de L205b : pas trop de perte, donc ça va




Signal sur la cathode de L204b, BdT libre, donc pas de synchro




Signal sur la cathode de L204b, BdT synchronisée

A noter que j'avais réglé la BdT pour visualiser exactement 2 périodes du signal d'entrée. Remarquer le pic provoqué par le déclenchement du trigger !
Voici une vidéo du même signal G que j'ai faite en manoeuvrant le bouton (rouge) de synchro de l'oscillo (cliquez sur la photo) :


Conclusion : La synchronisation a été vérifiée, je la considère donc opérationnelle.
Il me reste quelques "bricoles" : vérifier les potards (de mémoire le cadrage X n'est pas du bon type et ceui de réglage d'amplitude de la dent de scie "crachouille") et surtout étalonner l'appareil, c'est-à-dire reprendre les réglages afin qu'il puisse réellement faire des mesures (d'amplitude et de période)




à suivre ...