Reconstruction complète d'un oscilloscope Tektronix type 502A





Challenge
Etat des lieux
Vérification préliminaire du tube cathodique
Reconstruction envisagée
Alimentation générale
Calibrateur
Alimentation du tube cathodique
Amplificateurs verticaux
Interventions diverses




1. Challenge

Parfois, l'attrait technique nous fait faire des choses qui dépassent l'entendement ... et là, j'ai fait fort.

L'oscilloscope Tektronix type 502A est particulier : il possède un tube cathodique à 2 canons, autrement dit, c'est un "vrai" 2 voies. Pas besoin d'alterner ou de découper les 2 signaux comme sur un oscilloscope standard, non, là, les 2 signaux sont amplifiés par 2 amplis identiques et appliqués sur deux paires de plaques du tube cathodique.

Voilà pour l'attrait technique. A part ça, il n'a pas une bande passante démoniaque (1MHz), mais les amplis sont à entrées différentielles et surtout, il est à tubes.
Voici l'engin :


C'est tout de même un gros appareil : il pèse pas loin de 25kg, il a même deux poignées pour son transport !

Donc, j'en ai trouvé un sur EB, au Royaume Uni, à pas cher. Enfin, pas cher si on ne compte pas le port et les taxes d'importation. Et oui, maintenant, on paie des taxes sur les produits venant de la perfide Albion ....
Seulement, vous vous doutez bien qu'il y a une contre-partie. Et elle est de taille. L'appareil a été cannibalisé !

Les photos du vendeur étaient explicites, mais qu'est-ce que vous voulez, quand l'attrait technique est supérieur ... Voici quelques photos éloquentes :


Un petit plaisantin a tagué la face avant, très joli.








Impressionnant, non ?
Sur tous les boutons, il n'en reste que 3, mais à l'intérieur, c'est pire : les tubes ont disparu, mais leurs supports aussi, même les condos de filtrage. On a l'impression qu'une fois le ventilo retiré, le cannibale est entré et a tout emporté ... Il semblerait tout de même que tout ce qui est fixé derrière la face avant est encore là. Du moins, on voit des boites qui contiennent peut-être encore les composants d'origine.
Le boitier semble intact .... lol. Et le tube cathodique est présent (on se demande bien pourquoi il n'est pas en miettes)
A l'heure où je tape ces quelques lignes, je n'ai pas encore reçu l'épave. Je referai des photos de l'intérieur, capots retirés pour faire un état des lieux.

Maintenant, question qu'on peut se poser : "Que faire de cette épave ?". Récupérer ce qui reste (mais pourquoi faire ? Je ne peux même pas essayer de vendre le tube car il faudrait au moins m'assurer qu'il est opérationnel) ou alors ....
Ou alors, TOUT recâbler. Tâche impressionnante, mais pas impossible. Il faut savoir qu'il y a plus de 30 ans, j'avais récupéré dans une benne industrielle un Tektro 533A. Or, ce type est de la même époque que le 502A. Je l'avais entièrement démonté et même si j'ai utilisé quelques composants, il m'en reste pas mal, en particulier les tubes. Et dans un 533A, il y en avait aussi pas mal de tubes ...
Et quand on a déjà recâblé entièrement des châssis de postes Philips, on doit pouvoir y arriver ...
Bon, il est vrai que si à l'arrivée, je m'aperçois que le tube n'a pas apprécié le voyage, je pense que je n'entreprendrai pas ce challenge.
Mais s'il est intact, je me lancerai dans une aventure qui sera certainement la plus longue que j'aurai tentée.
Attendons alors le facteur ....



2. Etat des lieux

Voilà, le bébé est arrivé :


Bon, seule victime visible du transport : un bouton cassé sur les rares restants ...
Sans plus attendre, je retire les 2 flancs :


Intérieur, vu de la gauche




Intérieur, vu de la droite

Sans trop de surprise, l'intérieur est plutôt ... vide, cependant, ce n'est pas si vide qu'il n'y parait :



Ce modèle est équipé de platines imprimées à semi-conducteurs pour les 2 amplis verticaux
Il y a même 2 tubes (sur 4), et quelques transistors (mais la plupart sont absents)
On a donc affaire au dernier modèle de 502A car les premiers avaient leurs amplis verticaux entièrement à tubes. Il doit donc dater du début des années 1970 ...

C'est une bonne surprise, car je ne m'attendais pas à ce que les amplis soient là.




En revanche, l'alim a été complètement cannibalisée (même le transfo a disparu !)



Vue de dessus : l'alim du tube cathodique et tout l'étage base de temps / synchro ont été décâblés également ...



Vue de dessous : confirmation que l'alim a disparu. En revanche, tous les étages d'entrée sont là, c'est aussi une bonne chose





Les circuits des amplis, vus du dessous


Voilà. On peut dire que cet oscillo est une épave.
Certains étages ont totalement disparu, d'autres sont intacts. Il reste quasiment toutes les barrettes-relais en porcelaine (donc avec les straps, ce qui facilitera le recâblage) et il y a même quelques torons encore présents.
95% des composants fixés sur la face avant sont toujours là, y compris les commutateurs des entrées, et ça aussi, ça va aider.

Mais avant d'entreprendre une éventuelle reconstruction, je dois faire une "petite" vérification du tube cathodique.
En effet, s'il est cassé, ou même s'il a pris l'air, je m'arrêterai là, car à quoi bon tout reconstruire si je ne peux pas retrouver un tube cathodique ?



3. Vérification préliminaire du tube

En fait, en prenant les photos, je me suis aperçu que le tube ne tenait plus beaucoup dans son enveloppe en mu-métal. Pire : en bougeant le connecteur du culot, le tube n'avait pas l'air de bouger. Horreur : le verre serait-il cassé au niveau des canons ?
Le mieux est de déposer le tube et de l'inspecter :


Ouf, il n'est pas cassé !
C'est l'embase qui est décollée du verre et qui bouge, naturellement. J'ai passé un coup de linge humide pour nettoyer le verre, et j'ai enlevé les inscriptions faites au feutre, au diluant cellulosique, il a meilleure allure ...



L'étiquette Tektronix : c'est un T5021-2



C'est beau, un double canon, non ?

Le getter est toujours bien gris, donc il semblerait bien que le vide soit toujours OK, mais je préfère faire un test de chauffage des filaments :


Parfait !
Petite remarque : ce test ne permet pas de savoir si le vide est parfait, mais dans le cas d'une fuite complète, les filaments ne rougiraient pas du tout. D'autre part, j'ai remarqué que les broches latérales (les électrodes de déviation) étaient tordues. Dans ce cas, pas question d'essayer de les redresser : le risque est trop grand de casser la soudure verre-métal. Elles resteront tordues, tant pis.

Je peux donc entreprendre l'épopée du siècle : la reconstruction d'un 502A !
Mais avant tout, mettre de côté ce précieux tube cathodique :


Le tube est emballé dans 4 tours de papier bulles et rangé en lieu sûr ...

L'étape suivante est de tester le tube avec toutes les tensions sur les éléectrodes. Je pourrais faire des bidouilles avec des alims de labo, mais le mieux est de reconstruire les alimentations de l'oscillo, puisque de toute façon, il me les faudra pour la suite.



4. Reconstruction envisagée

Résumons donc la liste du travail :

- Recâbler l'alim générale
- Recâbler l'alim du crt
- tester le tube en statique
- rééquiper les amplis verticaux
- tester en mode XY (sur cet oscillo, on passe en XY en connectant les sorties d'un des amplis sur les plaques de déviation horizontale)
- Recâbler la base de temps complète
- Recâbler le calibrateur
- Réparer la mécanique (vis absentes, parties démontées, boutons à refaire ....)


Et puis toute autre chose qui pourrait apparaitre à refaire lors de cette reconstruction ....



5. Alimentation générale

Allez, c'est parti !

Le site Tekwiki fournit tous les plans et schémas, voici celui de l'alimentation générale du 502A:



L'alim est constituée de 4 régulateurs dont 3 pour les hautes tensions :


Alim -150V



Alim +100V



Alim +350V (et +485V non régulés)

et un régulateur pour le chauffage de certains tubes :


Alim -6,2V
Ce régulateur fournit une tension continue pour tous les tubes des préamplificateurs verticaux dans la première version (502) et seulement pour 2 tubes Nuvistor dans la version suivante (502A). En observant les circuits des amplis verticaux, je ne vois pas du tout de tubes, ni de supports (à part les 2 tubes de sortie). Donc, ce 502A est équipé de préamplis entièrement à transistors dont le site Tekwiki ne fait pas mention ...
Je ne vais donc pas câbler ce régulateur pour l'instant, me contentant de ne câbler que les régus hautes tensions.
Comme je n'ai pas le transfo du 502A, mais que j'ai celui du 533, je vais l'utiliser à la place.
Le 533 consommait plus que le 502A, donc qui peut le plus, peut le moins, ça devrait aller. Voici le transfo que j'ai :


Le transfo du 533

Sur le 533, les redresseurs sont des empilements au sélénium alors que sur le 502A, il y a 3 valves.


Transfo et redresseurs sur le 533

Cela veut dire que les enroulements HT du transfo du 533 n'ont pas besoin de prise médiane comme celui du 502A. La conséquence est que je dois faire la même chose : utiliser des ponts de diodes à la place des valves. Pas grave, ça modernisera l'appareil ...
Voici donc le schéma de l'alim que je vais reconstruire :


Schéma de l'alim (cliquer pour télécharger le PDF)


Tout d'abord, j'ai repéré les bornes du transfo :


Le transfo du 533, repéré
J'ai également testé les tensions et c'est OK. En bas, le strap pour câbler le primaire en 230V, ainsi que le câble secteur (provisoire)
Mécaniquement, ce transfo est plus gros que celui d'origine, mais il "passe" dans l'espace prévu :


Il suffit de percer des nouveaux trous de fixation ...



Traçage des trous de fixation et de la découpe nécessaire



Perçage d'une série de petits trous le long de la découpe
La matière est retirée à la pince, puis les bavures sont limées


Pour insérer le transfo, il faut pousser vers l'avant le commutateur de la base de temps
D'ailleurs, ce commutateur n'était plus fixé, puisque celui qui a déposé le transfo d'origine avait du, comme moi, le repousser vers l'avant. (l'axe sort alors de 10 cm de la face avant, avec son bouton)


Fixation du transfo. Détail amusant : les tiges sont filetées en M4, donc pas de souci pour trouver des écrous métriques



Ce transfo, un peu plus gros, tient comme prévu dans l'espace, mais c'est limite



Je peux réinstaller le commutateur à l'aide de 2 vis (sur 4) car je devrais sûrement le déposer pour le vérifier et/ou le recâbler
Pour faciliter les essais futurs, je dois confectionner un câble secteur. Coup de chance : la fiche est toujours embrochée dans l'embase, je n'ai donc qu'à raccorder un câble à 3 conducteurs :


La fiche et l'embase sont très spéciales
La fiche est démontable, pour connecter le câble. J'ai refait le circuit primaire, comprenant l'inter (couplé au potard de luminosité), le fusible et la sécurité thermique :


Circuit primaire du transfo (l'inter et la sécu sont de l'autre côté de la cloison)
Il faut maintenant que je fixe les supports de lampes, les condos de filtrage et les ponts de diodes. Je n'ai évidemment pas les condos d'origine et je ne vais pas mettre de ponts au sélénium. Donc j'ai imprimé des supports en PLA sur lesquels je monte les diodes et les condos modernes (encore des ersatz, donc ...) :


Les 2 types de ponts correspondants aux 5AR4 et à la 6BW4 ne sont pas identiques mécaniquement, mais les diodes sont les mêmes (1N4007)



Installation des supports de lampes, des ponts et des condos
C642, faisant partie du régu -6,2V n'est pas installé, donc il reste un trou inoccupé.
J'ai installé aussi les supports des 2 lampes du calibrateur, situé dans la même zone.
J'avais conservé pas mal de visserie américaine, ça sert toujours, la preuve ...


Les condos pourront plus tard être cachés dans des tubes que je rajouterai (mais ce n'est pas forcément nécessaire)



De l'autre côté de la cloison, les supports des lampes et les ponts



Avec les tubes, ça a déjà un super look, non ?
A noter que sur le 502A, les triodes-pentodes 6AN8 du 502 ont été remplacés par des 6BL8. C'est super, car la dénomination européenne des 6BL8 est ECF80. Et des ECF80, j'en ai un stock ... provenant de toutes les vieilles TV que j'ai démontées dans ma vie !
Bien, passons aux circuits de chauffage. Il y en a 2 : un pour les 12B4 du régulateur +350V et un second pour toutes les autres lampes de l'alimentation générale.
En effet, il ne faut pas que les circuits de chauffage soient portés à un potentiel trop grand par rapport à la cathode des lampes, il y a risque d'arc électrique interne. En général, on porte le circuit de chauffage à un potentiel proche de celui de cathode :


Circuits de chauffage
A gauche, le circuit des deux 12B4 est relié au +350V qui est justement le potentiel des cathodes.
A droite, le circuit des autres lampes, y compris les deux du calibrateur. Ce circuit est laissé en flottant.

Il n'y a plus qu'à câbler les 2 circuits :


Circuits de chauffage câblés
Il faut câbler les 2 fils à chaque fois, c'est un peu long, et il faut essayer de faire cheminer proprement les fils, mais il est inutile de les torsader.

Il n'y a plus qu'à vérifier si les lampes s'allument :


Question piège : pourquoi la lampe complètement à droite ne s'allume-t-elle pas ?
Je vérifie les tensions de chauffage :


Chauffage des deux 12B4 du +350V



Chauffage des autres lampes


Bien, ça c'était la mise en bouche ... maintenant, je passe aux choses sérieuses. Il faut recâbler tout ça ... J'ai tout de même un peu de chance car le cannibale a laissé les barrettes relais et il s'est contenté de jouer de la pince. Autrement dit, les ponts entre les bornes sont toujours là et les composants qui restent serviront de repères. De plus, sur Tekwiki, il y a une photo du câblage d'un 502A :


Câblage de l'alim
Tout n'est pas forcément visible, mais cette photo me sera d'une aide précieuse ! Pour m'aider, j'ai aussi le schéma électrique qui me servira à lever les ambiguités si la photo ne le peut pas.

Allez, au boulot. J'ai fait quelques photos des stades intermédiaires de câblage :


Régulateurs -150V et +100V câblés
J'ai pu réutiliser certaines résistances en rallongeant leur patte cisaillée. J'ai trouvé dans une boite où je conservais des vieilles résistances NOS, celles qu'il fallait, d'autant qu'à l'origine, leur tolerance est de 10%. Pour d'autres, j'ai du en mettre des nouvelles, quitte à faire des associations (c'est le cas de la 50k).


Régulateur +350V câblé
A ce stade, il ne reste pas grand chose à câbler : les 2 cellules de découplage formées des deux 100 ohms et des 2 condos de 22µF (C765), ainsi que la 15k du -100V. Mais l'ensemble est prêt pour les essais !

La mise au point a été assez rapide : j'avais oublié une connexion et une des ECF80 était trop faible. Une fois cela remis en ordre, j'ai pu régler le -150V et j'ai bien obtenu +100V et +350V des régulateurs. Le +485V est un peu fort (plus de 500V), mais l'alim est à vide ...


Tensions relevées dans le régulateur +350V



Tensions relevées dans le régulateur +100V



Tensions relevées dans le régulateur -150V

Parfait. Je n'ai plus qu'à fretter les torons pour éclaircir tout ça :


Alimentation générale prête
Note : sur les schémas, on trouve des résistances en parallèle avec les 12B4. Ces résistances, sans gêner la régulation, servent à "aider" les triodes série lorsque tous les consommateurs sont connectés. En effet, ces régulateurs ne sont pas faits pour une plage de variation de courant de 0 au maxi : en marche normale, le courant consommé varie peu. Par exemple, si la consommation sur un régulateur varie de 80 à 100mA en marche normale, on peut faire passer 60mA dans une résistance parallèle et la triode série n'aura à débiter que 20 à 40mA, ce qui la conservera plus longtemps. Je verrai donc, lorsque tout sera recâblé, quelles valeurs de résistances parallèle je pourrai installer.



6. Calibrateur

Bien que cet étage ne soit pas du tout nécessaire pour essayer le tube cathodique, il est installé à côté de l'alimentation générale, chauffé avec le même circuit, donc autant le câbler maintenant. De plus, le calibrateur pourra me servir lors des tests des amplificateurs verticaux.
Il ne comporte que deux lampes, donc ça devrait être rapide. Le seul point qui pourrait être ennuyeux est que le commutateur est en face avant et que le câble a été sectionné par le cannibale.

Voici son schéma, que j'ai refait à partir de ceux de Tektro car le schéma du 502A scanné n'est pas très lisible et celui du 502 comporte une triode-pentode 6AN8 alors que sur le 502A, c'est une 6BL8 :


Calibrateur du 502A
J'ai simplifié la représentation du commutateur car celui-ci est intact, protégé du cannibale par la face avant. Les 3 liaisons ont été cisaillées, mais c'est simple de les refaire.
Le câblage mérite de réfléchir un peu car il faut d'abord faire les liaisons aux supports de lampes avant de souder les composants sur les barrettes et ne pas utiliser les numéros de broches sur le schéma car la 6BL8 n'a pas le même brochage que la 6AN8:



Voici le câblage terminé :


Calibrateur câblé
Le potard de 10k avait disparu, j'en ai remis un. Il sert à régler exactement l'amplitude du signal rectangulaire à 50Vpp.
Le fil jaune sur la première borne à droite de la barrette en bas où est soudée la résistance de 51k, est le +100V; il est prélevé sur le condo C757B.
Le +350V de l'anode et de la grille 2 de V873B est prélevé sur la borne juste à côté, où les 2 résistances de 100 ohm sont soudées (+350V dclp).
En haut, entourés, les fils rouge, blanc et le coaxial allant au commutateur de la face avant :




Voici les signaux relevés dans cet étage :




Signaux du calibrateur
La fréquence est proche de 1kHz, mais vu les tolérances sur les composants (10%), inutile d'essayer d'avoir une référence de fréquence avec ce circuit; il servait donc uniquement de référence de tension pour les amplis verticaux.

J'ai relevé également les tensions (moyennes) sur les électrodes des lampes :


Tensions sur le calibrateur

Bien, calibrateur OK. Un coup de diluant pour effacer les inscriptions faites au feutre sur la face avant et il restera le bouton à remettre :



Suite : Alimentation du tube cathodique